Degraded performance on 3rd party service
Incident Report for Signicat2
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 19:03 CEST
Investigating
Onfido have degraded performance on creating checks
Posted Jun 05, 2024 - 18:17 CEST